search-replace-db-4.1.1をアップロードしても表示されない

ワードプレスサイトのドメイン変更中です。

  1. データベースのバックアップ取得済み
  2. ワードプレスファイル群のバックアップ取得済み
  3. コンフィグのデータベース情報書き換え
  4. ワードプレスファイル群アップロード
  5. データベースアップロード
  6. データベース内のドメイン情報置き換え←今ここ

データベース内のドメイン情報置き換えには、

なんか数字やらが関わってくるのでドメインだけの置き換えはダメだと読んで、

※参考こちら
https://site-hikkoshi.com/1006/

search-replace-db-4.1.1と言うツールを使っています。

※参考こちら
https://wheelchair-coder.com/281/

しかしまー。

説明通りに、サーバーにアップしたのに、アクセスできません。

階層も間違いないはずです。

でも、ゆう通りに、ブラウザでアクセスしてみても、表示されるはずのあの赤っぽい画面が表示されません。

このページは存在しません。

だってー!!!涙

ウィジェット系がうまく反映されてません。

やっぱり、データベースがをちゃんとしないといけない。

しかし、なぜあの赤っぽい画面が出てこないっっっ!

検索中・・・

解決策見つからず。

PHPのせいかもと思い始める。

最新バージョンなので、バージョンを下げる。

あ、エラー。

  • Xアクセラレータ Ver.2が有効なため、PHP 5.1に変更できません。

なるほど、ならばXアクセラレータとやらを解除しましょう。

そしてPHPバージョンを下げる。

非推奨って出てたけど、後で戻せばいいからいい。

search-replace-db-4.1.1が、使えればそれでいいっっっつ涙

さてhttp://ドメイン名/Search-Replace-DB-master/にアクセスしてみます。

ガーン。

堂々のエラー。popバージョン変えすぎですね。ごめんなさい。バージョン変えてみます。

Your server is running PHP version 5.3.3 but WordPress 5.4.2 requires at least 5.6.20.

引き続きエラー。

何か伝えたいなら、日本語で書いて欲しい。

さらにPHPバージョンの変更。

さて?表示されるかな?

エラーは解消になったものの、ページは表示されません。

PHPは関係ないんですね。

アクセラレータもPHPも元に戻します。

なんとわかりやすい画面で、エックスサーバー様様です。

またまた検索。

同じ人がいたーーーーーーーーー!!

https://teratail.com/questions/133678

多分移転先のほうのフォルダにアップロードしていないだけでは。

うーん。。。

何度確認しても、移転先にアップロードしてるんだけどなー。

ならば。

階層を変えてみる。

public_htmlにアップロードしてましたが、そこから出してみます。

これでどうだ!

ガーン

なんと言うことでしょう。全然だめ。

なんなの〜涙

もうね、そもそもファイルをもう一度ダウンロードしなおそうと思う。

https://interconnectit.com/products/search-and-replace-for-wordpress-databases/

きっと、元のファイルがおかしいに違いない!

そして別バージョンをダウンロードしました。

お願いだよー!

はい、ここにね!

 

ガーン

もう手が見つかりませぬ。

一体どうしたらいいんでしょう神様。

お皿洗いと洗濯物が溜まっています(主婦です)

これか・・??

https://blog.mohyo.net/2017/05/1931/

Search Replace DB にある「OLDER SERVER? TRY V 2.1.0」から、古いバージョンのSearch Replace DBをダウンロードしてきます。

いや、そんなファイル、ないわよ・・涙

こんなの発見!

https://www.idcf.jp/rentalserver/support/knowledge/wordpress/shift_03.html

この作業は、やってないなー!!

やってみよう!

と思ったけど、

// populate db details
$name = $database_opts[ ‘データベース名‘ ];
$user = $database_opts[ ‘データベースのユーザー名‘ ];
$pass = $database_opts[ ‘データベースのパスワード‘ ];
$host = $database_opts[ ‘127.0.0.1:(ポート番号)‘ ];
$port = $database_opts[ ‘3306‘ ];
$charset = ‘utf8’;
$collate = ”;

こんな項目、ないです。

ないのですー涙

多分、最初からやり直したほうがいいんだと思う。それこそ、元サイトからのバックアップからね。

だけど、もう電ちが切れました。私。

そもそも情報量も多くないサイトなので、ウィジェットはを一から設定し直したほうが早いのかも。

そうします。

めげないぞっっ涙

Follow me!